MeshNook技术与生活的角落

2009.08.11 · 1 分钟阅读

sun 250 sparc failed to boot from debian netinst cd

Today just want to install debian 5.0.0 on an old sun 250 sparc.

Then "memory not aligned" message was prompted when booting from the debian 5.0.0 netinst CD.

After googling, a very simple solution is found.

Turn off your server, and disconnect the power supply cable. Wait about
twice minutes and then turn on the server. Before do poweroff, I recommend
change the default load to CDROM device in order to avoid boot from Harddisk
device.

From the ok prompt:

ok setenv boot-device cdrom

and then,
ok reset-all

When the server has loaded, in the ok prompt:
boot cdrom

When you do not need anymore boot from cdrom, reboot the server and in the
ok prompt:
ok boot disk0:a
ok reset-all

Here is the original url.
http://groups.google.com/group/linux.debian.maint.boot/browse_thread/thread/6a67c351964a4bc5

Thanks for Fer R.